7 Replies Latest reply on Sep 30, 2021 5:43 PM by srini komm

    Secureagent

    srini komm Guru

      The Secure Agent runs with proxy servers. I am currently working on a task that loads data into an SOAP WebService, but the SOAP WebService does not allow proxy. I would like to configure the proxy to exclude non-proxy hosts from it. I have updated the proxy.ini file in this format

       

      InfaAgent.NonProxyHost=localhost| end point url

       

      Re-started the agent and re-running the job does not resolve the error.

       

      ERROR] Fatal runtime error occured : [com.sun.xml.ws.client.ClientTransportException: HTTP transport error: java.io.IOException: Unable to tunnel through proxy. Proxy returns "HTTP/1.1 403 Forbidden"]

       

       

       

      Can someone tell me if this is the correct format, whether to update the non proxy host, or if any other steps need to be taken.

        • 1. Re: Secureagent
          Ashwini Ramakrishna Guru

          Hello Srini,

           

          Please go through below KB's that can be used for your problem and let us know if it helped to isolate the issue :

           

           

          Support

           

          Support

          • 2. Re: Secureagent
            srini komm Guru

            I forget to mention that I've added JVM properties for non Proxy host at secure agent.

             

            Could you please confirm that this is the correct way to add non-proxy hosts to my proxy.ini file. Is there anything I'm missing.

            InfaAgent.NonProxyHost=localhost| end point url

            • 3. Re: Secureagent
              Ashwini Ramakrishna Guru

              Please have follow below steps and refer the KB articles provided :

               

              Configuring the proxy settings through JVMOptions

              1. Log in to Informatica Intelligent Cloud Services.

              2. Open Administrator and select Runtime Environments.

              3. Select the Secure Agent for which you want to configure a proxy server.

              4. On the upper-right corner of the page, click Edit.

              5. In the System Configuration Details section, select the Type as DTM for the Data Integration Service.

              • Add the following parameters in any JVMOption field and specify appropriate values for each

              parameter:

              Parameter Description

              -Dhttps.proxyHost= Host name of the outgoing HTTPS proxy server.

              -Dhttps.proxyPort= Port number of the outgoing HTTPS proxy server.

              For example,

              JVMOption1=-Dhttps.proxyHost=<proxy_server_hostname>

              JVMOption2=-Dhttps.proxyPort=<proxy_port>

              Configuring proxy settings 31

              6. Click Save.

              The Secure Agent restarts to apply the settings

              • 4. Re: Secureagent
                Jharana Patra Guru

                Hi Srini,

                 

                In the above mentioned parameter you have to append either Ip address which you want to bypass or mention only the hostname to get it allowed instead of whole URL.

                InfaAgent.NonProxyHost=localhost| end point url

                 

                ->Stop the agent, add the following lines to the end of proxy.ini ( available in $SecureAgent\apps\agentcore\conf  directory):

                InfaAgent.NonProxyHost=localhost|127.*|[::1]|*.<service name>|IP Address

                InfaAgent.NonProxyHosts=localhost|127.*|[::1]|*. <myserver .infa.com>|IP Address

                 

                * Please make sure you specify either the DNS or the HOST IP address of the service that you’re connecting to, within the NonProxyHost and the NonProxyHosts.

                 

                ->Start the agent and test the service connector. It should test fine.

                • 5. Re: Secureagent
                  srini komm Guru

                  've added the non proxy hosts in proxy.ini file in below format.

                   

                  Non-proxy hosts=abc\|bcd\

                  abc is the host name for one webservice and bcd is another hostname for other webservice. Is there anything I am missing here?

                  still abc webservice is running via proxy services.

                  • 6. Re: Secureagent
                    Jeffline Jenisha W Seasoned Veteran

                    Hi Srini,

                     

                    Was the secure agent service restarted after the change was made to the proxy.ini file? If not, please restart the same and see if the non-proxy host gets picked up.

                     

                    Also, I am including the link for another KB related to this below for your reference:

                    https://knowledge.informatica.com/s/article/532992?language=en_US

                     

                    Regards,

                    Jeffline

                    • 7. Re: Secureagent
                      srini komm Guru

                      Thanks for the info