0 Replies Latest reply on Sep 16, 2021 1:26 PM by Nico Heinze

    PowerCenter update and persistent LKP cache files

    Nico Heinze Guru

      Hi everyone,

       

      we're in the process of migrating from PowerCenter 10.1.1 HF1 to 10.4.1. During our tests one question came up for which we didn't find any answer, neither in the documentation nor on this forum.

      The point is this: there are some PowerCenter error messages which may be issued to a session log IF PowerCenter has been upgraded since the persistent LKP cache files have been created.

      Unfortunately it's not mentioned anywhere (at least not that I know of) in which versions of PowerCenter this message actually occurs (or did occur in the past).

       

      Can anyone (e.g. some Product Specialist from Informatica Global Customer Support or someone from R&D) confirm whether the structure of the persistent LKP cache files has been changed from 10.1.1 HF1 to 10.4.1?

      If yes, then we have to re-build all persistent lookup cache files during the final migration weekend, and this will become pretty nasty to organise.

      If no, then there's no need to re-build any cache files.

       

      At my current customer site we administrators do NOT know what special cases have been implemented over the past 15 years by the developers, so we cannot test all cases of persistent LKP cache files. It may well happen that during our tests everything works fine, and after the migration to 10.4.1 has been completed we wouldn't like to encounter that on next Monday morning dozens of workflows have failed in 10.4.1 because some developer had implemented some use case we have not foreseen. That's the reason why I am not confident that a simple test would be sufficient to "prove" that this should work fine.

       

      Thanks and regards,

      Nico