4 Replies Latest reply on Aug 31, 2021 3:35 AM by Bibek Sahoo

    Informatica Process Server not launch due to PostgreSQL database

    Andrei Pisarev New Member

      Hi,

       

      I can't start the Process Server, but the Common Integration Components and the Data Integration Server are running.

       

      At the bottom I brought logs, which show the problem with starting PostgreSQL and directory infaagent/apps/process-engine/data/PostGreSql/Data is really not exists

      Main menu

      Logs

       

      infaagent/apps/process-engine/logs/scripts.log shows the following:

       

      INFO - Could not start the PostgreSQL database.

      INFO [com.activee.rt.hub.agent.util.AeAgentShutdown] - Nothing to shutdown - Tomcat not running.

      INFO [com.activee.rt.hub.agent.util.AeAgentShutdown] - Unable to load the catalina.pid file required to terminate tomcat.

       

      infaagent/apps/agentcore/agentcore.log shows the following:

       

      ProcessMonitor [CommandSpec command[/home/mavericka/infaagent/apps/process-engine/10384521.1.1/.lcm/start-wrapper.sh] args[] dir[/home/mavericka/infaagent/apps/process-engine/10384521.1.1] timeout[3600000] waitForever[false]] state[EXITED] tmpFile[/home/mavericka/infaagent/apps/agentcore/logs/temp/ProcessSupervisor6381216991508092427.tmp] completed exit code: 201 output:

      chmod: unable to access к '/home/mavericka/infaagent/apps/process-engine/data/PostGreSql/Data': There is no such file or directory

      /tmp:5432 - no response

      Starting the PostgreSQL database.

      pg_ctl: directory "/home/mavericka/infaagent/apps/process-engine/data/PostGreSql/Data" does not exist

      /tmp:5432 - no response

      Could not start the PostgreSQL database.

      ProcessMonitor [CommandSpec command[/home/mavericka/infaagent/apps/process-engine/10384521.1.1/.lcm/stop-wrapper.sh] args[] dir[/home/mavericka/infaagent/apps/process-engine/10384521.1.1] timeout[300000] waitForever[false]] state[EXITED] tmpFile[/home/mavericka/infaagent/apps/agentcore/logs/temp/ProcessSupervisor5201666706507509148.tmp] completed exit code: 0 output:

      Nothing to shutdown - Tomcat not running.

      Unable to load the catalina.pid file required to terminate tomcat.