5 Replies Latest reply on Sep 22, 2021 10:49 AM by Shivanga Srinivas Bandaru

    ORA-12660: Encryption or crypto-checksumming parameters incompatible

    Ananth Suman New Member

      Hello Team,

       

      Kindly help me in resolving the below issue.

       

      Issue Description:

      ===============

       

      On Informatica version : Informatica 10.1.0 ,Customer is not able to start their informatica services /not able to connect to their database after changing the encryption method at the DB side. They had to change their encryption method due to some security reasons.

       

      ERROR:

      Unable to initialize persistence component due to: [PERSISTENCEAPI_0307] [DBPERSISTER_0009] Failed to connect to the database with JDBC connection string 'jdbc:informatica:oracle://xxxxxxx.com:<Port>;ServiceName=xxxxxxxxx.com;MaxPooledStatements=20;CatalogOptions=0;BatchPerformanceWorkaround=true' as user 'INFA10.' Verify that the connection string and user name are valid. This was caused by [informatica][Oracle JDBC Driver]ORA-12660: Encryption or crypto-checksumming parameters incompatible

      com.informatica.repository.persistence.PersistenceInitializationException: [PERSISTENCEAPI_0307] [DBPERSISTER_0009] Failed to connect to the database with JDBC connection string 'jdbc:informatica:oracle://xxxxxxx.com:<Port>;S

       

      Steps that we tried :

      =============

       

      1. Updating the Sqlnet.ora file .

       

      On the Server:


      SQLNET.ENCRYPTION_SERVER = [accepted | rejected | requested | required]
      SQLNET.ENCRYPTION_TYPES_SERVER = (valid_encryption_algorithm [,valid_encryption_algorithm])

      On the client:

          SQLNET.ENCRYPTION_CLIENT = [accepted | rejected | requested | required]
          SQLNET.ENCRYPTION_TYPES_CLIENT = (valid_encryption_algorithm [,valid_encryption_algorithm])

       

      2. ./infasetup.sh updategatewaynode -cs "jdbc:informatica:oracle://<host>:<port>;ServiceName=<ServiceName>;EncryptionLevel=required;EncryptionTypes=<DataEncryptionSettingOfYour OracleServer>;DataIntegrityLevel=required;DataIntegrityTypes=<DataIntegritySettingOfYourOracleServer>"

       

      And

       

      ./infasetup.sh updategatewaynode -cs "jdbc:informatica:oracle://<IP Adress>:1521;ServiceName=SXXXXTMQ;EncryptionLevel=required;EncryptionTypes=AES128;DataIntegrityLevel=required;DataIntegrityTypes=SHA1" -du XXX -dp XXX

       

      Research :

      ============

      https://knowledge.informatica.com/s/article/000138794?language=en_US

      https://knowledge.informatica.com/s/article/510152?language=en_US

      https://knowledge.informatica.com/s/article/000138794?language=en_US

      Also , the below guides might help.

       

      ORA-12660: Encryption Or Crypto-checksumming Parameters Incompatible When Connecting To Application (Doc ID 2395707.1)

       

      JDBC Thin Connections are Still Being Allowed to the Database after Setting SQLNET.ENCRYPTION_SERVER = REQUIRED on the Database Server (Doc ID 2242266.1)

       

      Unfortunately , nothing worked.