2 Replies Latest reply on Jul 28, 2021 9:33 PM by Jharana Patra

    Trouble mapping to UNC Path

    Melody Beacher New Member

      Please assist with trying to setup a Flat File Connection to a UNC path.

       

      Receiving errors that the directory does not exist, even though it is visible in File Explorer.

       

      We have the Cloud Secure Agent running as a service account with access to the directory. We have confirmed this access is working on the server.

        • 1. Re: Trouble mapping to UNC Path
          Teodoro Salluzzi Guru

          Hello Melody

           

          You might want to read this KB article if you're using an Agent running on Windows (as indicated by the fact that you're using file explorer).

           

          Please also check that the the user running the agent has full control over the file and parent folder.

          This normally works better when done explicitly on the user permission rather than on group permission.

          • 2. Re: Trouble mapping to UNC Path
            Jharana Patra Guru

            Hi Melody,

             

            Before configuring the connection, confirm that all the permissions from the current drive are enabled on the mapped drive.

             

            In Informatica Cloud Service, to configure a Flat File connection on a mapped drive, do the following:

            1. Ensure that the agent is running with a local user account and not the system account.
            2. Run the command net use x: <drive to me mapped> /persistent:yes.
              • Map the drive using a free alphabet.
            3. Provide the full path name in the Flat File connection.