3 Replies Latest reply on Jun 7, 2021 12:45 AM by user186817

    Error reading from DB2 table

    John Naiderman Active Member

      Hi All,

       

      I'm trying to read data from DB2 table. When I'm trying to create a relational data object of that type in the developer tool, I'm getting the below error message when trying to browse to see the tables under the specified connection:

       

       

      Because I couldn't create this object I used a dynamic JDBC source with the "at run time, get data objects columns from data source" option checked to try and see what happen in run time. I ran the mapping twice - once in native exec mode in other with Spark push-down and got the same error in both cases:

       

      Caused by: com.informatica.core.exception.IllegalArgumentException: [LDTMEXP_0029] Failed to process mapping because of following reason [java.lang.reflect.InvocationTargetException].

      ...

      Caused by: java.lang.RuntimeException: java.lang.RuntimeException: java.lang.RuntimeException: Unable to connect to the database.

      Reason=[jcc][10150][10300][3.72.30] Invalid parameter: Unknown column name TABLE_SCHEM. ERRORCODE=-4460, SQLSTATE=null. SqlState=null.

      ErrorCode=-4,460. Connection Name=. Database Type=com.informatica.adapter.infajdbc.InfaJDBCConnectInfo.

       

      Additional details:

       

      The connection config I used (I changed the host name and other sensitive data):

       

      I found some suggestion to try with the useJDBC4ColumnNameAndLabelSemantics=2; option but that didn't help either.

       

       

      I tries using two diffrent versions of the db2jcc.jar: 3.72.30 and 4.26.14 and both produced this error

       

      Does anyone encountered a similar issue?

       

      thanks,

      John