14 Replies Latest reply on Feb 28, 2021 10:22 AM by Rajan Rath

    RestoreDomain command failed during upgradation process

    Neha Garg Guru

      Hi,

       

      I am doing a parallel upgrade of IDQ 9.6.1 HF3 to IDQ 10.2.0 in a new machine. Before doing the upgrade I am trying to restore the backup of domain for 9.6.1 HF3, but its failing with below error :

       

      [ICMD_10033] Command [RestoreDomain] failed with error [[INFASETUP_10039] Cannot restore the domain because of the following error: [BACKUPRESTORE_0021] Incompatible product version or system schema version is missing. Verify that the back-up file being restored was created using the current version. Or, verify that the back-up file is not corrupted..].

       

      I have performed the following steps:

       

      1. Take a backup of the config folder <INFA_HOME>/isp/config.

      2. Backup the existing domain using the below command:

       

      infasetup BackupDomain -cs "jdbc:informatica:sqlserver://dbhost:port;DatabaseName=DOM_DQ_DEV1;SnapshotSerializable=true;allowPortWithNamedInstance=true" -du <user> -dp <pass> -dt MSSQLServer -bf D:\Informatica_bkp\INFA_Domain_bkp.mrep -dn <domain name>

       

      3. Copy the backup file to the new machine.

       

      4. Install the existing version of Informatica on the new machine.

      5. Cancel the install before configuring the domain.

       

      6. Click Quit when the install prompts to create or join domain.

      7. Copy the files in the <INFA_HOME>/server/infa_shared directories on the original machine to the new machine.

      8. Restore the domain in a new database or database schema using the infasetup RestoreDomain command and the domain backup.

      Using the below command:

      infasetup RestoreDomain -cs "jdbc:informatica:sqlserver://dbhost:port;DatabaseName=DOM_DQ_DEV1;SnapshotSerializable=true;allowPortWithNamedInstance=true" -du <user> -dp <pass> -dt MSSQLServer -bf D:\Informatica_bkp\INFA_Domain_bkp.mrep -ca

       

      But the RestoreDomain command is failing with the below error:

       

      [ICMD_10033] Command [RestoreDomain] failed with error [[INFASETUP_10039] Cannot restore the domain because of the following error: [BACKUPRESTORE_0021] Incompatible product version or system schema version is missing. Verify that the back-up file being restored was created using the current version. Or, verify that the back-up file is not corrupted..].

       

      Please suggest what can be the issue as I have followed all the steps carefully.

       

      Thanks

      Neha