1 2 Previous Next 27 Replies Latest reply on Jul 9, 2020 6:37 PM by Tharini V

    Informatica Admin Console page is not coming up

    Michele DuBose Active Member

      Hello, I have Informatica 9.5 installed on a Windows 2008 server. I've recently had to restart the Informatica 9.5 service because I was unable to connect to the Informatica Integration Service. As a result of restarting the Informatica Service, the Admin Console site does not come up. I get "The site can't be reached" error. I've tried going to the site on the server where Informatica application runs, and my pc. I get the same behavior on both machines. Also, on the server, I've tried http://localhost:port/administrator. Same behavior. Before restarting the Informatica 9.5 service, the Admin Console came up. Is there a service that did not start?

        • 1. Re: Informatica Admin Console page is not coming up
          user126898 Guru

          how did you restart the domain?  what cmd in what dir?

           

          Have you looked at the cataline.out or exceptions.log on the master node to debug the start up?

           

          thanks,

          Scott

          • 2. Re: Informatica Admin Console page is not coming up
            Sven Benzing Guru

            Hi Michele,

             

            as Scott mentioned first of all we need to verify if the Informatica Administrator is starting or not,

             

            There is a very good KB article available which might help you:

             

            https://kb.informatica.com/howto/6/Pages/17/334583.aspx

             

            Kind regards,

             

            Sven

            • 3. Re: Informatica Admin Console page is not coming up
              Smitha HC Guru

              1.Check the Catalina.out log for any errors. If Domain process has started successfully then you would have errors in th node.log. If the domain process itself has not started then we need to check further.

              2.If it issue with only Adminconsole process.As mentioned in the KB article provided by Sven, you can troubleshoot further.

              Attach catalina.out and node.log

               

              Thanks,
              Smitha

              • 4. Re: Informatica Admin Console page is not coming up
                Pavan kumar Guru

                Hi Michele,

                 

                You might can try steps in below order:-

                 

                 

                1. First check if Admin Console process is running or not on Informatica server machine. Refere below KB :-

                 

                 

                https://kb.informatica.com/faq/7/Pages/4/173439.aspx

                 

                 

                2. If it is not running, try to start by running 'infacmd.bat isp enableservice -sn _AdminConsole' from $INFA_HOME/isp/bin directory.

                 

                 

                - If it is still not running, please check node.log and catalina_<timestamp>.log files. (node.log is in $INFA_HOME/tomcat/logs directory and catalina_<timestamp>.log is in $INFA_HOME/tomcat/temp/_AdminConsole/logs directory).

                 

                 

                3. Also, try tomcat clean-up. Do as follows:

                 

                 

                   - Shutdown Informatica.

                   - Delete all the content under the $INFA_HOME/tomcat/work directory.

                   - Delete all the content under the $INFA_HOME/tomcat/logs directory.

                   - Delete all the content under the $INFA_HOME/tomcat/temp directory.

                   - Delete all the directories under the $INFA_HOME/tomcat/webapps directory (Do not touch/delete the .war files).

                   - Delete all the directories from $INFA_HOME/services/AdministratorConsole/webapps directory (Do not touch/delete the .war files).

                   - Start Informatica.

                  

                4. If the issue still occurs, share node.log and catalina_<timestamp>.log file along with screenshot from browser when you are accessing the Admin Console.

                 

                 

                Thank you,

                Pavan

                • 5. Re: Informatica Admin Console page is not coming up
                  Michele DuBose Active Member

                  Hi Pavan kumar,

                   

                  These are the steps that I've taken to troubleshoot.

                  1. Checked the node.log file located under $INFA_HOME/tomcat/logs.  I see the following errors:

                   

                  2020-06-30 09:15:10,661 ERROR [Thread 6 of 6 in DomainServiceThreadPool] [SPC_10059] The Service Manager cannot start a service process for service [Informatica Administrator]. Verify that port number [8003] is not in use, and restart the service.

                  java.net.BindException: Address already in use: JVM_Bind

                  2020-06-30 09:15:10,661 ERROR [Thread 6 of 6 in DomainServiceThreadPool] [SPC_10053] The Informatica service cannot start Informatica Administrator on port [8002]. Run the infasetup UpdateGatewayNode command to specify another port number for Informatica Administrator.

                   

                  2.  I do not see any logs from catalina.log file located under $INFA_HOME/tomcat/temp/_AdminConsole/logs for today's date

                   

                  3.  I've ran the following command to start the Admin Console to see if that helped

                  infacmd enableService -dn <Domain_Name> -un -pd -sn _AdminConsole

                  After running the above command, I've received the attached error.

                   

                  The errors indicate an issue with the port but I'm unsure the reason.  Also, how do I go about changing the port?

                  • 6. Re: Informatica Admin Console page is not coming up
                    Tharini V Active Member

                    Hi Michele,

                     

                    To change the Admin Console port number, follow the below steps:

                     

                    1. Take a backup of nodemeta.xml file present in INFA_HOME/isp/config directory. Ensure that Informatica Services are down.

                     

                    2. Execute the below command from INFA_HOME/isp/bin directory:

                     

                    infasetup UpdateGatewayNode -ap <new_admin_console_port>

                     

                    If you are using HTTPS for Admin Console, then try with the below command:

                     

                    infasetup UpdateGatewayNode -hs <new_admin_console_port> -kf <keystore_file> -kp <keystore_password>

                     

                    3. Once the execution of above command is successful, you can restart the Informatica Services.

                     

                    Thanks,

                    Tharini.

                    • 7. Re: Informatica Admin Console page is not coming up
                      Michele DuBose Active Member

                      Hi Tharini V, Thanks for the steps.  How do I determine what port number to change to?

                      • 8. Re: Informatica Admin Console page is not coming up
                        Tharini V Active Member

                        Hi Michele,

                         

                        You can use any of the available/free ports. Please use netstat commands to verify whether a specific port is free or not.

                         

                        Example:

                         

                        netstat -anp | find ":<port number>"

                         

                        Thanks,

                        Tharini.

                        • 9. Re: Informatica Admin Console page is not coming up
                          Michele DuBose Active Member

                          Are there a list of ports I can use as a guide to search?

                          • 10. Re: Informatica Admin Console page is not coming up
                            David Lopez Cruz Seasoned Veteran

                            Hi Michele,

                            default port is 6008 or 8443 for https, but you can define anyone that you know is going to be free in your environment.

                             

                            Regards,

                            David

                            • 11. Re: Informatica Admin Console page is not coming up
                              Smitha HC Guru

                              Hi Michele,

                               

                              You can refer below KB, which has a list of default ports used by Informatica application. You can use any one of the port apart from these ports.

                               

                              112395

                               

                              Thanks,

                              Smitha

                              • 12. Re: Informatica Admin Console page is not coming up
                                Michele DuBose Active Member

                                Thank you.  Before, I look into changing the port for the Admin Console page, is there a reason why port 8002 in which my Admin page is currently using, doesn't work anymore?

                                • 13. Re: Informatica Admin Console page is not coming up
                                  Smitha HC Guru

                                  Hi Michele,

                                   

                                  From the error which you have shared, it seems to be port is used by another process.

                                   

                                  The Service Manager cannot start a service process for service [Informatica Administrator]. Verify that port number [8003] is not in use, and restart the service.

                                   

                                   

                                  java.net.BindException: Address already in use: JVM_Bind

                                   

                                  So, we are requesting to change the port. Or you have to kill the process which is using port 8003. so that Adminconsole can come up.

                                   

                                  Thanks,

                                  Smitha

                                  • 14. Re: Informatica Admin Console page is not coming up
                                    Michele DuBose Active Member

                                    Port 8003 is in use but port 8002 is not.  Port 8002 is what my admin page is pointing to. I've verified that port 8002 isn't used by running the below command.

                                    netstat -ao | find "LISTENING" | find "8002"

                                     

                                    When the command is executed, I did not get an output which tells me that port 8002 is available. What doesn't make sense to me is the reason, I get a "Page cannot be display" message when going to the Admin page URL if port 8002 is available.

                                     

                                    Also, I'm following the troubleshooting steps in this KB and in Step#2, I ran the below command to verify if Admin Console java process is running.  However, I get a "-ps is not recognized" error.  Can I run the following command on a Windows server?

                                    ps -fe | grep <username> | grep _AdminConsole

                                     

                                    In task manager, I see a java process listed. However, the username is System and not the Informatica service user name that infasvcs uses.  Shouldn't there be a java process running that's connected to Informatica?  What's listed in task manager seems to be the java process for the server.

                                     

                                    Thanks again for your insight.

                                    1 2 Previous Next