4 Replies Latest reply on Jun 9, 2020 6:28 AM by Spidy 2406

    Informatica PIM 10 server not running

    Spidy 2406 Active Member

      Hi Everyone,

      I have installed Informatica PIM 10 clusterix and server on windows machine. Clusterix service is up and running. Installed the server but when i start the server service, it is started and stopping immediately. Can someone help me here, I have attached the console log file.

        • 1. Re: Informatica PIM 10 server not running
          Sai Narasimha Prasad Rebba Guru

          Hi,

           

          I can see the following error from the logs

           

          INFO   | jvm 1    | 2020/05/31 19:28:23 | java.lang.IllegalArgumentException: Invalid broker URI: <ENTER MESSGAE QUEUE URL HERE, e.g. tcp://localhost:61616>

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at org.apache.activemq.ActiveMQConnectionFactory.createURI(ActiveMQConnectionFactory.java:170)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at org.apache.activemq.ActiveMQConnectionFactory.<init>(ActiveMQConnectionFactory.java:131)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at com.heiler.ppm.messagequeue.server.v2.internal.reader.JMSReader.<init>(JMSReader.java:69)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at com.heiler.ppm.messagequeue.server.v2.internal.JMSMessageQueue.getReader(JMSMessageQueue.java:47)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at com.heiler.ppm.dataquality.server.internal.queue.DataQualityQueueInitializer.initDQMessageQueue(DataQualityQueueInitializer.java:57)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at com.heiler.ppm.dataquality.server.internal.queue.DataQualityQueueInitializer.initialize(DataQualityQueueInitializer.java:48)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at com.heiler.ppm.platform.server.internal.ServerContainer$ServerInitializerCallable.call(ServerContainer.java:372)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at com.heiler.ppm.platform.server.internal.ServerContainer$ServerInitializerCallable.call(ServerContainer.java:1)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at java.util.concurrent.FutureTask.run(FutureTask.java:266)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at java.lang.Thread.run(Thread.java:748)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | Caused by: java.net.URISyntaxException: Illegal character in scheme name at index 0: <ENTER MESSGAE QUEUE URL HERE, e.g. tcp://localhost:61616>

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at java.net.URI$Parser.fail(URI.java:2848)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at java.net.URI$Parser.checkChars(URI.java:3021)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at java.net.URI$Parser.checkChar(URI.java:3031)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at java.net.URI$Parser.parse(URI.java:3047)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at java.net.URI.<init>(URI.java:588)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | at org.apache.activemq.ActiveMQConnectionFactory.createURI(ActiveMQConnectionFactory.java:168)

          INFO   | jvm 1    | 2020/05/31 19:28:23 | ... 11 more

           

           

           

          It means that the ActiveMQ (i.e,. Message Queue) installation is mandatory for PIM 10.

           

          Install message queue and configure it PIM server that should work fine.

           

          Thank you

          Sai Prasad

          • 2. Re: Informatica PIM 10 server not running
            Spidy 2406 Active Member

            Hi Sai,

             

            Thanks for your response!!

             

            I have installed the ActiveMQ given by Informatica. After the installation when i am trying to start the service of ActiveMQ , it is giving me the error as

            " Windows could not start the Informatica PIM ActiveMQ service on Local Computer.

             

            Error 1067: The process terminated unexpectedly".

             

            Could you please guide me here. I have attached the screenshot of the error.Thanks in advance.

             

            Regards,

             

            Dilip

            • 3. Re: Informatica PIM 10 server not running
              Sai Narasimha Prasad Rebba Guru

              Hello Dilip,

               

              This could be some generic error. Please check the following link

               

              https://support.threattracksecurity.com/support/solutions/articles/1000070946-error-1067-process-unexpectedly-terminated-when-starting-vipre-service#:~:text=The%20Error%201067%20error%20code,the%20performance%20of%20a%20computer.&text=This%20damaged%20system%20file%20will,optimal%20working%20of%20the%20application.

               

              And one suggestion is don't keep any spaces in full path to MessageQueue directory and see if the ports that used by messaged are allowed or blocked by someother processes or services.

               

              Thank you
              Sai Prasad

              • 4. Re: Informatica PIM 10 server not running
                Spidy 2406 Active Member

                Hi Sai,

                 

                Thanks for your response!!  Even after installing the Active MQ  server was not running due to below issues

                 

                1. I have not defined and configured the new PIM user for Console initially - I have corrected this.

                2. Did not change the Active MQ integration details in the server.properties - I have corrected this.

                 

                After doing above changes, server is running fine .. Thanks for your help