7 Replies Latest reply on Nov 8, 2019 2:27 AM by Ralph Wittig

    Problems after Migration to SDK version 8.1.1.03.07

    Christian Wagner Active Member

      After the migration from PIM SDK 8.1.1.02.02 to PIM 8.1.1.03.07 the PIM Server runs into the following error durring the startup procedure and stops working.

       

       

      ....

      14:30:09,259 INFO  [ServerInitializer 1] (ConsoleProgressMonitor.java:130) -   KPI initialization completed (Duration: 30 ms)

      14:30:10,123 INFO  [ServerInitializer 6] (ConsoleProgressMonitor.java:130) -   DataQuality Component completed (Duration: 892 ms)

      14:30:10,127 ERROR [main] (PlatformContainer.java:512) - Exception during initialization, startup terminated.

      14:30:10,128 ERROR [main] (PlatformContainer.java:513) - Internal error in initializer dataquality.component

      java.lang.NoClassDefFoundError: com/informatica/imf/icore/IMFRuntime$IEncryptionProvider

      at com.heiler.ppm.dataquality.server.internal.DataQualityComponent$DataQualityLifeCycle.initialize(DataQualityComponent.java:338)

      at com.heiler.ppm.platform.server.internal.ServerContainer$ServerInitializerCallable.call(ServerContainer.java:291)

      at com.heiler.ppm.platform.server.internal.ServerContainer$ServerInitializerCallable.call(ServerContainer.java:1)

      at java.util.concurrent.FutureTask.run(FutureTask.java:266)

      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

      at java.lang.Thread.run(Thread.java:748)

      Caused by: java.lang.ClassNotFoundException: com.informatica.imf.icore.IMFRuntime$IEncryptionProvider cannot be found by com.heiler.ppm.dataquality.server_1.0.0.r64464

      at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:423)

      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:336)

      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:328)

      at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)

      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)

      ... 7 more

      14:30:10,131 INFO  [main] (ConsoleProgressMonitor.java:130) - Start completed (Duration: 48748 ms)

      14:30:10,132 ERROR [main] (MainServerApplication.java:89) - Error during startup of server

      org.eclipse.core.runtime.CoreException: Internal error in initializer dataquality.component

      at com.heiler.ppm.platform.server.internal.ServerContainer$ServerInitializerCallable.call(ServerContainer.java:301)

      at com.heiler.ppm.platform.server.internal.ServerContainer$ServerInitializerCallable.call(ServerContainer.java:1)

      at java.util.concurrent.FutureTask.run(FutureTask.java:266)

      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

       

      I´ve also tried to setup a new Eclipse Workspace, installed the Target Platform (as described in your SDK-Document "How to setup the Target Definition") and tried to use the configuration, I´ve found in the Project "HENRI" from Informatica. But always the error message at the the point of time if I start the PIM Server out of Eclipse IDE.
      The Launch Configuration of our old version and the new Version 8.1.1.03.07 that Informatica has delivered hasn´t changed.

       

      Has anyone had the same problem and / or knows how to solve it ?

      Thank you for every hint to solve the problem ,-)