3 Replies Latest reply on Mar 14, 2019 2:48 PM by Mohammad Khan

    Fault message Data

    kiran kaur New Member

      <messageData xmlns:S="http://schemas.xmlsoap.org/soap/envelope/"
                  
      xmlns:ns2="http://schemas.active-endpoints.com/engineapi/2010/05/EngineAPITypes.xsd"
                  
      xmlns:ns4="http://schemas.active-endpoints.com/engineapi/2010/09/ProcessManagementTypes.xsd"
                  
      xmlns:ns3="http://schemas.active-endpoints.com/activebpeladmin/2007/01/activebpeladmin.xsd"
                  
      name="automatedStepFault"
                  
      namespaceURI="http://schemas.active-endpoints.com/wsdl/screenFlow/2010/10/avosAutomatedStep.wsdl">
        
      <part name="automatedStepFaultResponse">
           
      <aetgt:faultResponse xmlns:aetgt="http://schemas.active-endpoints.com/appmodules/screenflow/2010/10/avosScreenflow.xsd"
                                
      xmlns:xsd1="http://schemas.active-endpoints.com/appmodules/screenflow/2010/10/avosScreenflow.xsd">
              
      <xsd1:code>CreateDataException</xsd1:code>
              
      <xsd1:reason/>
           
      </aetgt:faultResponse>
        
      </part>
      </messageData>

       

      as per https://kb.informatica.com/solution/23/pages/66/532767.aspx  , i did republish process and connections , but it didnt help

        • 1. Re: Fault message Data
          Mohammad Khan Active Member

          Hi Kiran,

           

          What type of connection you are using in the process ? Is it a JDBC connection ?

           

          I have seen this error in cases where a process tries to insert data to a DB table using a create step and field assignments in the create step contain incorrect data .

           

          If you are seeing this error in the same scenario , I suggest you double check that the data which is being inserted to the DB table is valid . For testing purposes , you can try manually running a SQL to insert the same data to the DB table and see if the data gets inserted .

           

          I also suggest you take a look at Catalina.log  \ Catalina.out and see if there are any more details on this error .

           

          Thanks,

          Mohammad

          • 2. Re: Fault message Data
            kiran kaur New Member

            Hi Mohammed,

             

            Yes i am using JDBC connector.

            Insert is working fine throu' ICS task. I tried to play with Process and got following error,

             

            <xsd1:code>CreateDataException</xsd1:code><xsd1:reason>Do not map any auto increment fields. The following fields have been mapped: [[SID]] </xsd1:reason></aetgt:faultResponse>



            SID is auto incremental , where as i cannot delete it from process as it is required field



            • 3. Re: Fault message Data
              Mohammad Khan Active Member

              Hi Kiran,

               

              I have seen cases where  mapping the auto increment field does not work and the process faults .

               

              In this case , If possible , I suggest you modify the  DB table to make the auto increment field as  not required ,  re-publish the JDBC connection , modify the process to exclude the auto increment field and then re-publish it and see if it works .

               

              Thanks,

              Mohammad