7 Replies Latest reply on May 30, 2019 11:30 PM by Lakhwant Singh

    Oracle 12 c and 18c supported by Informatica 9.61

    Naveen Kumar Dasu New Member

      Hi All,

       

      Just want know does the Informatica 9.61 supports Oracle 12 c and 18c. We have a DB Upgrade and looking for the Support matrix for all Apps.Want to check for Informatica as well.

       

       

      Regards,

      Naveen

        • 1. Re: Oracle 12 c and 18c supported by Informatica 9.61
          Eren Görmez New Member

          Hi Naveen,

           

          Informatica doesn't support Oracle 18c. 9.6.1 HF4 is support 12cR1.

           

          Regards.

          Eren

          • 2. Re: Oracle 12 c and 18c supported by Informatica 9.61
            Peter Land New Member

            It's always best to check the Product Availability Matrices.

            PAM for Informatica 9.6.1 HotFix 4

            as mentioned above, 9.6.1 HF 4 supports Oracle 12cR1

             

            Informatica 10.2 HF 1 supports Oracle 12cR2:

            PAM for Informatica 10.2 HotFix 1

            • 3. Re: Oracle 12 c and 18c supported by Informatica 9.61
              Rajan Rath Guru

              Hello Naveen,

               

              I believe you have already reviewed the PAM for the support matrix on Oracle 12c for different versions.

              Informatica currently does not support Oracle 18c. The support for Oracle 18c will be made available in the upcoming releases.

               

              Regards,

              Rajan

              • 4. Re: Oracle 12 c and 18c supported by Informatica 9.61
                Lakhwant Singh Active Member

                Any idea in which version they will support 18c?

                We have hit a bump as our source DB is 18c but PWX does not support it. We are on latest version 10.2 HF2 and it is compatible with 12cR2 at the most.

                • 5. Re: Oracle 12 c and 18c supported by Informatica 9.61
                  Nico Heinze Guru

                  No one can tell for sure. You might open a service request at Informatica Global Customer Support, and they can tell you, the expected version which will support 18c is x.y.z. But they cannot tell (in fact no one can) whether this will be the case until the version is published.

                   

                  There have been releases in the past where it was "commonly expected" that certain features would be integrated into the software. But several times during the past 18 years these expectations were not met by reality. There can always be reasons for a software vendor to delay (or even drop) certain features even though many customers expect these new features. As a software vendor you should never give guarantees for new features; there can always be obstacles which you cannot anticipate.

                   

                  On your behalf I would "simply" go back to 12c with regard to PowerCenter.

                  If Oracle supports the use of the 12c OCI client with a 18c DBMS, then you can expect your mappings and sessions to run against 18c sources, targets, and lookup tables (provided you don't use any SQL overrides which no longer work under 18c, but that's your own risk), but the repositories should remain in 12c. No matter what your internal release plan says or what your management expects. Technical necessities are nothing which your management can enforce.

                   

                  Regards,

                  Nico

                  • 6. Re: Oracle 12 c and 18c supported by Informatica 9.61
                    Rajan Rath Guru

                    Hello Lakhwant,

                     

                    Are you sure you have reviewed the correct PAM for Informatica 10.2.0 HF2?

                    I had a quick check and see Oracle 18c to be supported in Informatica 10.2.0 HF2.

                     

                    Regards,

                    Rajan

                    • 7. Re: Oracle 12 c and 18c supported by Informatica 9.61
                      Lakhwant Singh Active Member

                      PWX 10.2 HF2 will need an EBF on top of it to provide support for 18c. But that too only for the features that are in 12cR2. In other words, PQX 10.2 HF2 + EBF will provide support with 18c provided you do not use new features of 18c. In a way, it is kind of tolerance support for 18c. Full 18c support is expected in PWX 10.4 by end of year.

                       

                      As per Informatica support:

                      For PowerExchange CDC for Oracle Express, we will provide an EBF on top of PowerExchange CDC for Oracle Express 10.2.0 HF2, within the May timeframe. That (EBF) will provide equivalent supported functionality for PowerExchange CDC for Oracle Express that we have for Oracle 12cR2 for Oracle 18c. Potential exploitation of any new Oracle 18c features in PowerExchange CDC for Oracle Express would come towards the end of the year via additional EBF’s or next release