11 Replies Latest reply on Oct 12, 2018 7:40 AM by Daniel McCahon

    Secure Agent CIH Processor stuck in deploying

    Daniel McCahon New Member

      Hi,

      I am new to Informatica Cloud and am working trough the IICS Cloud101 course on the Informatica University. After installing the secure agent on my device, the Data Integration and Process Servers have both deployed and started successfully, but the CIH Processor is stuck in deploying and in the Service Agent Details on the Cloud Admin>Runtime Environments the service is listed at Starting up. Any help with this would be greatly appreciated. Also, I have restarted the agent and then reinstalled to try resolve the issue.

        • 1. Re: Secure Agent CIH Processor stuck in deploying
          Varun Kumar Yella Seasoned Veteran

          It happened for me as well. to resolve this, try installing secure agent in another machine and access informatica cloud from your system. it works!

          • 2. Re: Secure Agent CIH Processor stuck in deploying
            Mohit Yadav Guru

            Hi Daniel,

             

            Are you seeing any file with name 'Informatica' under the C:\Program Files or the directory where you have installed the secure agent and is the content of that file is something like '14961 Cloud Secure Agent\apps\CIHProcessor\conf\cih_processor_secure_channel_port.properties'

             

            Then  navigate to the directory: {agent.dir}\Informatica Cloud Secure Agent\apps\CIHProcessor\ 7.1 and edit the file startup.bat as below:

             

            Note that the earlier entry of the file was something like below:

             

            Note: The only change was the value of the property 'CIH_SECURE_PORT_TMP_FILE' where we have hardcoded the actual location of the directory instead of using the environment variable %APP_DIR%

            Restart the secure agent after making above changes and the CIH service should come up fine now.

             

            ~Mohit

            • 3. Re: Secure Agent CIH Processor stuck in deploying
              Daniel McCahon New Member

              Hi Mohit,

               

              Thank you for your help, i have made the recommended changes however when i restart the agent it quickly fails and shows message The Secure Agent has been stopped. I have tried reinstalling the Agent and reapplying your fix however the same error appears. Any idea why this is?

               

               

              Thanks again.

              Daniel.

              • 4. Re: Secure Agent CIH Processor stuck in deploying
                Mohit Yadav Guru

                Hi Daniel,

                 

                can you try to start the secure agent from services and let me know what error message you are getting?

                 

                ~Mohit

                • 5. Re: Secure Agent CIH Processor stuck in deploying
                  Daniel McCahon New Member

                  Hi Mohit,

                  This is the error I receive:

                  Thanks,

                  Daniel.

                  • 6. Re: Secure Agent CIH Processor stuck in deploying
                    Mohit Yadav Guru

                    Hi Daniel,

                     

                    Please check if there is any file with the name 'Program' in C:\ drive or in the drive where you installed the agent.

                    Or if there is any file with name 'Informatica' inside C:\Program Files, if there delete that file as well.

                    Delete both the above files and then start the secure agent.

                     

                    ~Mohit

                    • 7. Re: Secure Agent CIH Processor stuck in deploying
                      Daniel McCahon New Member

                      Hi Mohit,

                      This has resolved the Agent not starting error, but the CIH Processor is still not working correctly.

                       

                      Thanks,

                      Daniel

                      • 8. Re: Secure Agent CIH Processor stuck in deploying
                        Mohit Yadav Guru

                        Hi Daniel,

                         

                        Good to know that at-least secure agent is able to come up.

                         

                        For CIH issue, please paste the content of the startup.bat file here. You can find the file on below location:

                        {agent.dir}\Informatica Cloud Secure Agent\apps\CIHProcessor\7.1

                         

                        Also, I want to know what is the directory location, where you installed the secure agent?

                         

                        ~Mohit

                        • 9. Re: Secure Agent CIH Processor stuck in deploying
                          Daniel McCahon New Member

                          Hi Mohit,

                           

                          Thanks again for your help the Agent was installed in the default location which is C:\Program Files\Informatica Cloud Secure Agent

                           

                          The start up file is as follows:

                           

                          @echo off

                          set CIH_APP_DIR=%APP_DIR%\%APP_CURRENT_VER%

                          set DEBUG_OPTIONS=

                          REM set DEBUG_OPTIONS=-Dlog4j.debug -Xdebug -Xrunjdwp:transport=dt_socket,address=2238,server=y,suspend=n -ea -esa

                          set CIH_SECURE_PORT_TMP_FILE=C:\Program Files\Informatica Cloud Secure Agent\apps\CIHProcessor\conf\cih_processor_secure_channel_port.properties

                           

                           

                          IF EXIST %CIH_SECURE_PORT_TMP_FILE% (

                              del %CIH_SECURE_PORT_TMP_FILE%

                          )

                           

                           

                          echo %CIH_PROCESSOR_TOMCAT_PORT%>%CIH_SECURE_PORT_TMP_FILE%

                           

                           

                          set CIH_OPTS=-Dserver.port=%CIH_PROCESSOR_TOMCAT_PORT%

                          set CONF_FOLDER=%CIH_APP_DIR%\conf

                          set VERSION=10.4.0-CIH

                          set CIH_JAR_PATH=%CIH_APP_DIR%\lib\cih-package-%VERSION%.jar

                           

                           

                          if not exist "%AGENT_JAVA_HOME%\bin\java.exe" goto noJavaHome

                          set JAVA=%AGENT_JAVA_HOME%\bin\java.exe

                          goto javaIsSet

                           

                           

                           

                           

                          :noJavaHome

                          echo.

                          echo Warning: JAVA_HOME environment variable is not set. Exiting.

                          echo.

                          exit /B 101

                           

                           

                           

                           

                          :javaIsSet

                          REM set DEBUG_OPTIONS=-Dlog4j.debug -Xdebug -Xrunjdwp:transport=dt_socket,address=2238,server=y,suspend=n -ea -esa

                          echo [%~n0 ] %date% %time% Starting CIHProcessor application. Executing ["%CIH_JAR_PATH%"] >> "%CIH_APP_DIR%\logs\scripts.log"

                          start "" "%JAVA%" -Dloader.path="%CONF_FOLDER%" %DEBUG_OPTIONS% %CIH_OPTS% -jar "%CIH_JAR_PATH%" start

                          echo [%~n0 ] %date% %time% CIHProcessor application has been started. Error code is: [%ERRORLEVEL%] >> "%CIH_APP_DIR%\logs\scripts.log"

                           

                           

                          exit /B %ERRORLEVEL%

                           

                          Thanks,

                          Daniel.

                          • 10. Re: Secure Agent CIH Processor stuck in deploying
                            Mohit Yadav Guru

                            Hi Daniel,

                             

                            Please use the double quotes in the below line:

                            set CIH_SECURE_PORT_TMP_FILE="C:\Program Files\Informatica Cloud Secure Agent\apps\CIHProcessor\conf\cih_processor_secure_channel_port.properties"

                             

                             

                            Wrap the path in double quotes.

                            It should come up fine.

                             

                            ~Mohit

                            • 11. Re: Secure Agent CIH Processor stuck in deploying
                              Daniel McCahon New Member

                              Perfect! Thanks very much Mohit!

                              Thanks again,

                              Daniel.