5 Replies Latest reply on Jun 20, 2018 10:20 PM by James Barker

    Axon 5.2.0 Unison Microservice: Unknown :: Service is unavailable

    Aike Sass New Member

      Hi,

       

      I just installed Axon 5.2.0 and when accessing Axon the following error message pops up:

       

      Unison Microservice: Unknown :: Service is unavailable

       

      I cannot find any errors in the log files. I found the following link AXON-3663 : In Axon v5.2, Unison Microservice unavailable error message pops up  but there is no solution described.

       

      How can I solve this issue?

       

      Kind regards

        • 1. Re: Axon 5.2.0 Unison Microservice: Unknown :: Service is unavailable
          ltrapadoux Guru

          hi Aike,

           

          this has happened to me while the internal hostname of the machine and the hostname use to access the URL are different. is this the case for you ?

           

          to resolve this, you can edit the file parameters.ymlc  in <axon-install-dir>/axonhome/axon-config and change the parameter axon_unison_host

           

           

          once changed you need to cleanup the cache folder in

           

          <axon-install-dir>/axonhome/axon/app/cache/prod/

           

          rm -Rf *

           

          and restart the cache server

           

          <axon-install-dir>/axonhome/third-party-app/scripts/memcached restart

           

          thank you

           

          Louis-Noël

          • 2. Re: Axon 5.2.0 Unison Microservice: Unknown :: Service is unavailable
            James Barker New Member

            Louis-Noel this is a helpful post...I have had the same challenge.

             

            Could you post an example of what this setting should look like.  I have tried to make this change with no change in results.

             

            Thanks for any guidance you can provide.

            • 3. Re: Axon 5.2.0 Unison Microservice: Unknown :: Service is unavailable
              ltrapadoux Guru

              hi James,

               

              the parameter should look like :

               

              axon_unison_host: http://<hostname>:<port>/unison

               

               

              also please check if the unison process is running:

               

              ps -edf | grep unison

               

              root       6923      1  0 Jun18 ?        00:02:59 /root/Informatica/axon5.2.0/axonhome/java/jre/bin/java -cp unison-service-1.0-SNAPSHOT-all.jar:lib/* com.infa.products.axon.unison.UnisonApplication server config/app.yml

              • 4. Re: Axon 5.2.0 Unison Microservice: Unknown :: Service is unavailable
                James Barker New Member

                For anyone who is having issues in Axon 5.2 with the install in particular the error that "Unison Microservice is not available" and have verified that the microservice is running.

                 

                This thread was incredibly helpful to find the issue, but while this may be the intent of how things are intended to work, I found that there is another instance of this same file that is located at:

                <<Axon Install Directory>>/axonhome/axon/app/config

                 

                This is the key to solving this.

                 

                The file is parameters.ymlc

                 

                It is the same file as in the axon-config directory but this version of the file is read at startup of the microservices...

                 

                I am going to log a note with support on this, but hopefully this reference will really help folks out.

                 

                The bottom line...if you run the whole install and get this error message, go and change the setting for axon unison host...and things should work for you.

                 

                I hope this helps...Louis-Noel thanks for pushing me in the right direction.

                 

                Jim

                • 5. Re: Axon 5.2.0 Unison Microservice: Unknown :: Service is unavailable
                  Aike Sass New Member

                  Hi Louis-Noël,

                   

                  thanks a lot! That solved the issue!

                   

                  I used the URL configured in the parameter file and it worked.

                   

                  Kind regards

                  Aike