5 Replies Latest reply on Jun 19, 2017 11:57 PM by Siva kumar
      • 1. Re: Unable to login to DVO client by using Informatica authentication
        Guru

        I know it sounds silly, but have you tried writing Administrator instead of administrator (uppercase A at the beginning)?

         

        Regards,

        Nico

        • 2. Re: Unable to login to DVO client by using Informatica authentication
          Siva kumar Active Member

          Thanks for the response Nic. I tried with the upper case too and still it is throwing error as "Internal Error".

           

          It was working fine without informatica authentication. But after enabling it, it throws error. I check the domains.infa file and the domain name is fine.

           

          Will there be any issues if we open the DVO client in interactive mode??

           

          Also tried to update and disable informatica authentication by using DVOCmd commands, but it shows the following error for both.

           

          Syntax

          DVOCmd DisableInformaticaAuthentication --confdir C:\Informatica DVO 10.0.0\DVO --username administrator --password *******

           

          PowerCenter Data Validation Command 10.0.0 Release Build (r1306330)

          Copyright (c) Informatica LLC, 2015. All rights reserved.

          ERROR: Please make sure you have configured the Database settings  under Tools >Preferences in PowerCenter Data Validation Client. Additional information: java.io.FileNotFoundException: C:\Informatica\preferences.xml (The system cannot find the file specified)

           

          The error is preferences.xml is missing. But we had already configured the preferences in the DVO client and so it would have already created. Can you help?

          • 3. Re: Unable to login to DVO client by using Informatica authentication
            Guru

            Does the preferences.xml file reside in directory C:\Informatica ?

             

            If so, could you please check the properties for this file whether the Windows user ID running DVO has full access to this file?

             

            Regards,

            Nico

            • 4. Re: Unable to login to DVO client by using Informatica authentication
              Siva kumar Active Member

              Able to find the preferences.xml file inside different location(C:\Users\Administrator\DataValidator). Have aopied the same to C:\informatica. The username and also the  DB connection properties are fine. Still facing issues

               

              Regards

              Siva

              • 5. Re: Unable to login to DVO client by using Informatica authentication
                Siva kumar Active Member

                I was not able update or disable informatica authentication using DVOCmd since the OS platform where we have installed DVO Client is not a certified one from PAM Document of informatica DVO 10.0.

                 

                Hence some of the featues wont work properly. But found a way to disable the informatica authentication directly in the DB schema to which we would have configured the DVO Client.

                 

                Search for the table, "DV_GLOBAL_OPTIONS" in the DB schema where you have configured DVO.

                 

                You can find columns "OPTION_NAME" and "OPTION_VALUE" with the values updated as 'EnableInfaAuthentication' and 'true' respectively.

                 

                Write an update statement to update the value to 'false'.

                 

                Query

                UPDATE "DV_GLOBAL_OPTIONS"

                SET OPTION_VALUE = 'false'

                WHERE OPTION_NAME = 'EnableInfaAuthentication'


                Now open DVO Client and it will not ask for informatica authentication.

                (NOTE: Make sure the DVO Client is not opened while updating in the DB)