1 2 3 Previous Next 31 Replies Latest reply on Aug 23, 2019 6:40 AM by sdepriest

    DTM Buffer issue

    New Member

      We just did an upgrade from Powercenter 9.5.1 to 9.6.1 Hotfix 2. We are beginning to see the following error:

      Message Code: DBG_21699

      Message: The reader is waiting for the DTM to provide buffer blocks. To improve session performance and to prevent the session from hanging, increase the DTM buffer pool size in the session properties.

       

      We didn't change our code between the migration and our jobs have gone from processing in 1.5 hours for 60 million rows to 24-48 hours. I have seen other messages around increasing buffer and DTM buffer. I have tried that and am still receiving the same message. What I would like to find out is why we are starting to see this in 9.6.1 and we never saw this in 9.5.1. Is there a change in the way informatica is allocating this or is it a configuration item in the admin console. Would really like to understand so we can mitigate the issues as quickly as they arise. Does one of the more recent HotFix packs fix this issue?

        • 1. Re: DTM Buffer issue
          milkman Guru

          I have run into a very similar issue. I have upgraded from 9.5 to 10.1, and get the same issue. I have nearly 1000 workflows, so tuning each one is not an option. The one example I have would run in 2 minutes in the 9.5 environment but anywhere from 20 minutes to 90 minutes in the v10.1.  Is there something at the IS level, I can change?

          • 2. Re: DTM Buffer issue
            Balaji Gubiligari Active Member

            In your jobs are you using AUTO setting for DTM buffer size ? Any reason you upgraded to 9.6.1 HF2 instead of 9.6.1 HF4 ? I believe 9.6.1 HF4 is more stable.

             

            Balaji

            • 3. Re: DTM Buffer issue
              New Member

              I have reached out to our infrastructure team to confirm the hotfix on the repository in case I am not seeing it correctly on my side so I will include that answer in the next response. Yea I am using AUTO as my setting. The only piece that changed from my side is the environment version. We didn't change our code or session values. It appears that John had the same issue but was apart of version 10. To his point is there configuration in the Admin console that could cause this?

              • 4. Re: DTM Buffer issue
                New Member

                What value you are able to see in session log for DTM Buffer Size and Buffer Block Size ?

                • 5. Re: DTM Buffer issue
                  sdepriest Seasoned Veteran

                  I'm seeing this debug error also.  We are testing a workflow that we upgraded from 9.1 to 9.6.1 HF3 to 10.1 and are seeing the error in 10.1.

                   

                  Only the message is slightly different.

                   

                   

                  Severity: INFO

                  Timestamp: 9/1/2016 4:30:24 PM

                  Node: NODE1_DEVTEST

                  Thread: READER_1_1_1

                  Process ID: 11200

                  Message Code: DBG_21699

                  Message: Waiting for consumer to free buffer block. Please increase the dtm buffer pool size.

                   

                  My Default buffer block size is Auto.

                  My Maximum Memory Allowed For Auto Memory Attributes property is 512M

                  My Maximum Percentage of Total Memory Allowed For Auto Memory Attributes property is 5.

                  My DTM buffer size is also Auto.

                   

                  Just encountered it so will have to research further and possibly submit to tech support.

                   

                  Sarah

                  • 6. Re: DTM Buffer issue
                    milkman Guru

                    I also use the same settings as Sarah. I have created a Support case for this.

                    • 7. Re: DTM Buffer issue
                      sdepriest Seasoned Veteran

                      Good deal.  I have submitted a ticket also on this.  My 9.1 session finished completely in 20 seconds and this same session in 10.1 went over 14 minutes before I aborted it. 

                      • 8. Re: DTM Buffer issue
                        New Member

                        Severity: INFO

                        Timestamp: 8/12/2016 2:17:03 PM

                        Node: pwc_prod_nhplavcs2131

                        Thread: READER_1_1_1

                        Process ID: 13432

                        Message Code: DBG_21699

                        Message: The reader is waiting for the DTM to provide buffer blocks. To improve session performance and to prevent the session from hanging, increase the DTM buffer pool size in the session properties.

                         

                         

                        Severity: INFO

                        Timestamp: 8/12/2016 2:15:45 PM

                        Node: pwc_prod_nhplavcs2131

                        Thread: MAPPING

                        Process ID: 13432

                        Message Code: TM_6660

                        Message: Total Buffer Pool size is 6000000 bytes and Block size is 142976 bytes.

                        • 9. Re: DTM Buffer issue
                          sdepriest Seasoned Veteran

                          Hi Mr. milkman, have you received any response from tech support?

                           

                          They are "still looking into the issue" in my open case and haven't provided me any insight on the issue or its possible resolution.  We are now ready to start the heavy testing and I have many sessions that use the AUTO DTM Buffer settings and am anticipating performance issues. 

                           

                          Sarah

                          • 10. Re: DTM Buffer issue
                            milkman Guru

                            No they have not. They have asked for more information and I have provided. Same boat as you (:

                            • 11. Re: DTM Buffer issue
                              sdepriest Seasoned Veteran

                              An update on my issue.  I did further testing and updated tech support, asking them to escalate the problem.  They are supposed to get back to me on Monday September 12th.

                              It seems to be an issue with building the lookup cache when there are lots of rows to cache.  We experienced it with a cache of 3.6 million rows, 4.6 million rows, and even 250,000 rows.  The time it takes to cache is double what it took in PowerCenter 9.1.  My lookup cache settings are also Auto and not a custom value.

                              I was able to prove the lookup cache issue by reducing the number of cached rows to less than 1000.  When I did that (entered a WHERE clause in the lookup SQL Override), the cache finished building and the session finished properly.  Of course I can't do that in all cases.  And again, it is working just fine in our production 9.1 environment.

                               

                              If I hear more next week, I'll update this post.

                               

                              Sarah

                              • 12. Re: DTM Buffer issue
                                milkman Guru

                                Interesting.  We seem to center  around what Oracle drivers (and/or Client) that was used to import the source/target object.  When running with a Oracle connection, the test we have been running has taken any ware from 30 minutes to 2 hours whereas currently in production it is about 2.5 minutes. We ran the test using ODBC oracle drivers, and it at least ran in 7 minutes.

                                • 13. Re: DTM Buffer issue
                                  台北 Connie Wang New Member

                                  Hi, we are facing the same problem: DBG_21699. Did your problem get solved? Would you please share your solution?

                                   

                                  Kind Regards, Connie

                                  • 14. Re: DTM Buffer issue
                                    sdepriest Seasoned Veteran

                                    Connie & Milkman,

                                     

                                    The ultimate solution for us was to use a custom property in the session and we left the DTM Buffer settings all at Auto.  The custom property is DisableStaticCursorsForSQLServerODBCProvider = Yes.

                                     

                                    They had internal discussions with the Engineering Team, Advanced Product Specialists team, and R&D teams and let me know about this flag.  We added it to our session in which we were having performance issues and they finished in the same amount of time as they do in version 9.1.

                                     

                                    We are using the ODBC choice as the Provider Type for SQL Server relational connections and we are using Auto for DTM Buffer Pool size.

                                     

                                    The case was open from September 2nd to October 7th, and there were lots of conversations, so if you have more specific questions, post them here and I can try to answer.

                                     

                                    Thanks

                                    Sarah

                                    1 of 1 people found this helpful
                                    1 2 3 Previous Next