0 Replies Latest reply on Jul 11, 2016 8:46 PM by longxing lin

    ultra message source configure

    longxing lin New Member

      HI:

          when l run a workflow which contains  ultra message source,it failed;

          here is error code and xml configuration,can everyone help me?thanks!

          The red font is the place where I change;

       

          

          <um-configuration version="1.0">    <templates>        <template name="tcpContext">            <options type="context">                <option name="fd_management_type" default-value="epoll" />                <!-- For windows -->                <!-- <option name="fd_management_type" default-value="wincompport" /> ->                <!-- For unicast resolver -->                <!--<option name="resolver_unicast_daemon" defaultvalue="192.168.66.128:15380" />                 <option name="resolver_unicast_port_high" default-value="17600" />                <option name="resolver_unicast_port_low" default-value="17500" />-->                                <!-- For multicast resolver -->                 <option name="resolver_multicast_address" default-value="192.168.66.128"/>                                <option name="transport_tcp_maximum_ports" default-value="20" />                <option name="transport_tcp_port_low" default-value="16500" />                <option name="transport_tcp_port_high" default-value="16600" />                <option name="response_tcp_nodelay" default-value="1" />                <option name="request_tcp_port_low" default-value="10000" />                <option name="request_tcp_port_high" default-value="11000" />            </options>            <options type="receiver">                <option name="use_late_join" default-value="1" />            </options>        </template>    </templates>    <applications>        <application name="UMApp">           <contexts order="allow,deny">                <!-- Streaming contexts -->                <context name="streamingReaderContext" template="tcpContext">                    <options />                </context>

       

      <context name="streamingWriterContext" template="tcpContext">                    <options />                </context>                <!-- Store contexts -->                <context name="storeReaderContext" template="tcpContext">                    <options />                </context>                <context name="storeWriterContext" template="tcpContext">                    <options type="source">                        <option name="late_join" default-value="1" />                        <option name="retransmit_retention_age_threshold"                           default-value="100" />                        <option name="ume_store" default-value="192.168.66.128" />                        <option name="ume_store" default-value="192.168.66.128" />                       <option name="ume_store" default-value="192.168.66.128" />                    </options>                </context>                <context name="storenameWriterContext" template="tcpContext">                    <options type="source">                        <option name="late_join" default-value="1" />                       <option name="retransmit_retention_age_threshold"                            default-value="100" />                        <option name="ume_store_name" default-value="JMSStore1" />                        <option name="ume_store_name" default-value="JMSStore2" />                        <option name="ume_store_name" default-value="JMSStore3" />                    </options>                </context>

                       <!-- ulb contexts -->                <context name="ulbReaderContext" template="tcpContext">                    <options type="receiver">                        <option name="umq_receiver_type_id" default-value="7" />

                      </context>                <context name="ulbWriterContext" template="tcpContext">                    <options type="source">                        <option name="umq_ulb_application_set" default-value="0:101" />                    </options>               </context>

                       <!-- uim contexts -->                <context name="uimWriterContext" template="tcpContext">                    <options />                </context>                <context name="uimReaderContext" template="tcpContext">                    <options type="context">                        <option name="request_tcp_port" default-value="20000" />                    </options>                </context>            </contexts>        </application>    </applications> </um-configuration>