1 Reply Latest reply on Sep 20, 2012 11:54 AM by John Ratelle

    Cannot open any report in reporting service

    Active Member

      In the [Find] tab, when I click any report. I get error msg "An unexpected exception has occurred. Please try again."

       

      The log in Administrator Console shows "serviceType serviceName severity timestamp threadName messageCode message

      RPS AQDT_RPT_SVC_DEV 1$_:_$ERROR 09/19/2012 05:47:20.580 AM http-0.0.0.0-16080-67 RPS_19999 User:

      administrator@Native

      , Session: 2178, Source: Web

      "

       

      When I double click the report, I get error msg "org.springframework.remoting.RemoteAccessException: Cannot access remote service [java:/comp/env/ejb/iasEjb/InfQueryReportManagerEJB]; nested exception is java.rmi.ServerException: EJBException:; nested exception is: javax.ejb.EJBException: Data source Datasource has been disabled. Please enable it and try again."

       

      The log in Admin Console shows "serviceType serviceName severity timestamp threadName messageCode message

      RPS AQDT_RPT_SVC_DEV 1$_:_$ERROR 09/19/2012 05:47:20.585 AM http-0.0.0.0-16080-67 RPS_19999 User:

      administrator@Native

      , Session: 2178, Source: Web, Message: 'Exception in load report :org.springframework.remoting.RemoteAccessException: Cannot access remote service [java:/comp/env/ejb/iasEjb/InfQueryReportManagerEJB]; nested exception is java.rmi.ServerException: EJBException:; nested exception is:

      javax.ejb.EJBException: Data source Datasource has been disabled. Please enable it and try again.'"

       

      I've no idea how to fix it, please advise.

        • 1. Cannot open any report in reporting service
          John Ratelle Guru

          Try a restart of the reporting service.

           

          Goto Adminitration tab, and then under Schema Design, select 'Data Sources'

           

          There should be one called Datasource - click on the Disabled to enable it.

           

          By default, when a Reporting Service is enabled for the a data source called Datasource is created and cannot be edited - this default data source can only be editted if

          Data Source Advanced Mode is checked (set to TRUE) under Reporting Service Properties

          - you could check this as well changing this requires a restart.

           

          Or if you have not created any Reports, and are only using the default reports - you could try creating another reporting service or delete/recreate the contents of the existing one.

           

          If none of these are working, open a Service Request with Global Customer Support.

          1 of 1 people found this helpful