5 Replies Latest reply on Apr 1, 2013 2:53 PM by michan

    Invalid Java Build installing PowerCenter 9.5.1

    Seasoned Veteran

      Hi,

      Getting invalid Java Build when installing PowerCenter 9.5.1.  Java build is "pap6460sr9fp2-20110627_03". not available for download.  Have install the latest Java available for download and still does not work.

       

       

      $ ./install.sh

      The INFA_JDK_HOME path is valid.

      OS detected is AIX

      \***************************************************************************

      \* Welcome to the Informatica 9.5.1 Server Installer. *

      \***************************************************************************

        

        

      Before you continue, read the following documents:

      * Informatica 9.5.1 Installation Guide and Release Notes.

      * B2B Data Transformation 9.5.1 Installation, Configuration Guide and Release Notes.

      You can find the 9.5.1 documentation in the Product Documentation section at http://mysupport.informatica.com.

      Configure the LANG and LC_ALL variables to generate appropriate code pages and

      create and connect to repositories and Repository Services.

      Do you want to continue? (Y/N)Y

      Installer requires operating system AIX version 6.1 Technology Level 05 and later or AIX version 7.1.

      Current operating system AIX version 6.1 Technology Level 07.

      Current operating system meets minimum requirements.

      Validating the INFA_JDK_HOME path.

      The INFA_JDK_HOME path is valid.

      Validating the Java version.

      The valid Java version is "1.6.0".

      The Java build that is currently installed is not valid.

      The valid Java build is "pap6460sr9fp2-20110627_03".

      Exiting the installation.

      $

       

       

       

       

       

      $ java -version

      java version "1.6.0"

      Java(TM) SE Runtime Environment (build pap3260sr9fp2-20110627_03(SR9 FP2))

      IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 AIX ppc-32 jvmap3260sr9-20110624_85526 (JIT enabled, AOT enabled)

      J9VM - 20110624_085526

      JIT  - r9_20101028_17488ifx17

      GC   - 20101027_AA)

      JCL  - 20110530_01

      $

        • 1. Invalid Java Build installing PowerCenter 9.5.1
          Active Member

          The version of java listed out in the release notes & the installer is the exact version that you need to have.  You cannot have a higher version of java.

          1 of 1 people found this helpful
          • 2. Invalid Java Build installing PowerCenter 9.5.1
            Srikanth Vishnuvajhala Guru

            did you run the i9pi before running the installer?

             

            https://communities.informatica.com/docs/DOC-7310

             

            Thanks,

            Srikanth

            • 3. Re: Invalid Java Build installing PowerCenter 9.5.1
              Guru

              You have to use the 64bit java - your java version is ppc-32 that should be ppc-64.

               

              Srini is also correct the installer is hardcoded to use one jvm version.

              1 of 1 people found this helpful
              • 4. Re: Invalid Java Build installing PowerCenter 9.5.1
                karthick lokala Guru

                As said by the experts, please review the java compatability before installing Informatica, and also run the i9pi tool before starting the actual Informatica installation.

                 

                i9pi pre installation check will provide you details on the issues for your operating environment (like connections, compatability etc), if there are any.

                 

                 

                Thanks

                Karthick  

                • 5. Invalid Java Build installing PowerCenter 9.5.1
                  Seasoned Veteran

                  Thanks everyone for your response.  I was able to install PC951 with SR9.

                   

                  Now when trying to install PC951 HF1, I need SR 12  built install.

                   

                  $ ./install.sh
                  The INFA_JDK_HOME path is valid.
                  OS detected is AIX
                  unjar task is in progress.............
                  unjar of ESD completed.....
                  Do you want to continue installation (y/n) ?
                  y
                  Starting installation ...

                  \***************************************************************************
                  \* Welcome to the Informatica 9.5.1 HotFix 1 Server Installer.  *
                  \***************************************************************************

                   

                  Before you continue, read the following documents:
                  * Informatica 9.5.1 HotFix 1 Installation Guide and Release Notes.
                  * B2B Data Transformation 9.5.1 HotFix 1 Installation, Configuration Guide and Release Notes.

                  You can find the 9.5.1 HotFix 1 documentation in the Product Documentation section at http://mysupport.informatica.com.

                  Configure the LANG and LC_ALL variables to generate appropriate code pages and
                  create and connect to repositories and Repository Services.
                  Do you want to continue? (Y/N)Y
                  Installer requires operating system AIX version 6.1 Technology Level 05 and later or AIX version 7.1.
                  Current operating system AIX version 6.1 Technology Level 07.
                  Current operating system meets minimum requirements.
                  Validating the INFA_JDK_HOME path.
                  The INFA_JDK_HOME path is valid.
                  Validating the Java version.

                  The valid Java version is "1.6.0".
                  The Java build that is currently installed is not valid.
                  The valid Java build is "pap6460sr12-20121025_01".
                  Exiting the installation.

                  $ pwd