4 Replies Latest reply on Jun 16, 2021 4:23 PM by Srinivas Pai

    EDC upgrade to v10.5 - Error  during ldm Catalog BackUp

    Anish Gupte New Member

      Hi Folks,

       

      I am having trouble running the back up contents command to back up contents of the Catalog Service while performing an in place upgrade to v10.5

       

      [ICMD_10033] Command [backupContents] failed with error [[LDMCMD_20003] Failed to get access to [Domain_sats4.localdomain] as user [Administrator] because [[JSF_0053] Name service lookup operation of service [/coreservices/DomainService] on domain [sats4.localdomain:6005] failed because of the following reason:[[SSLUtil_0001] Internal error. Secure communication failed because of the following SSL error: TrustStore was tampered with, or password was incorrect. Contact Informatica Global Customer Support.].]. Verify that the service name is correct and the user exists with required privileges.].

       

       

      I get the above error when I run the ./infacmd.sh LDM Backupcontents command. Here is the full command I am executing :

       

      [ec2-user@sats4 bin]$./infacmd.sh LDM backupContents -dn Domain_sats4.localdomain -un Administrator -pd admin -sn Catalog_Service -sdn Native -of /home/infa/Informatica/10.4.0/isp/bin/104_Catalog_Backup.zip

       

      As per the instructions in the knowledge guide, and also per a couple of KB articles (https://knowledge.informatica.com/s/article/574345?language=en_US) I found on this topic, I created an encrypted password using the ./pmpasswd command , and also set the INFA_HOME, LD_LIBRARY_PATH, INFA_TRUSTSTORE and INFA_TRUSTSTORE_PASSWORD variables , but no luck.

       

      Here is a full snapshot of the steps I have done so far -

       

      [ec2-user@sats4 bin]$ export INFA_HOME=/home/infa/Informatica/10.4.0

      [ec2-user@sats4 bin]$ export LD_LIBRARY_PATH=$INFA_HOME/server/bin

      [ec2-user@sats4 bin]$ ./pmpasswd changeit -e CRYPT_SYSTEM

       

       

      Informatica PowerMart Password Encryption Utility, 64-bit

      Copyright (c) Informatica LLC 1993-2020

      All Rights Reserved.

       

       

      Encrypted string -->XGghBX4AZZY0S8oYaqxVqA==<--

      Will decrypt to  -->changeit<--

      [ec2-user@sats4 bin]$ export INFA_TRUSTSTORE=$INFA_HOME/services/shared/security

      [ec2-user@sats4 bin]$ export INFA_TRUSTSTORE_PASSWORD=XGghBX4AZZY0S8oYaqxVqA==

      [ec2-user@sats4 bin]$ cd ../../isp/bin

      [ec2-user@sats4 bin]$

      [ec2-user@sats4 bin]$ ./infacmd.sh LDM backupContents -dn Domain_sats4.localdomain -un Administrator -pd admin -sn Catalog_Service -sdn Native -of /home/infa/Informatica/10.4.0/isp/bin/104_Catalog_Backup.zip

      [ICMD_10033] Command [backupContents] failed with error [[LDMCMD_20003] Failed to get access to [Domain_sats4.localdomain] as user [Administrator] because [[JSF_0053] Name service lookup operation of service [/coreservices/DomainService] on domain [sats4.localdomain:6005] failed because of the following reason:[[SSLUtil_0001] Internal error. Secure communication failed because of the following SSL error: TrustStore was tampered with, or password was incorrect. Contact Informatica Global Customer Support.].]. Verify that the service name is correct and the user exists with required privileges.].

       

      Can someone please help me out this this issue ? Thank ou so much in advance,

       

        • 1. Re: EDC upgrade to v10.5 - Error  during ldm Catalog BackUp
          Mayank Raoka Seasoned Veteran

          Hi Anish,

           

          Disable catalog service and run below command

          ./infacmd.sh LDM backupContents -dn Domain_sats4.localdomain -un Administrator -pd admin -sn Catalog_Service -of /home/infa/104_Catalog_Backup.zip

           

          Regards,

          Mayank Raoka

          • 2. Re: EDC upgrade to v10.5 - Error  during ldm Catalog BackUp
            Darren Wrigley Guru

            changeit is the wrong password for the infa truststore (infa_truststore.jks) - you should set the location of INFA_TRUSTSTORE to $INFA_HOME/services/shared/security & encrypt the right password and store that in INFA_TRUSTSTORE_PASSWORD

             

            here is a link describing the process:-

            https://knowledge.informatica.com/s/article/597392?language=en_US&type=external

            • 3. Re: EDC upgrade to v10.5 - Error  during ldm Catalog BackUp
              Chet Justice New Member

              In the Upgrade Guide there are 2 sections that mention backing up the Catalog.

              On p. 17, (1) Back Up Catalog Data Using the Export Utility, and on p. 18 (just following the other), there's (2) Back Up the Catalog Using the LDM backupContents Command.

              This was confusing to me (~2 years experience with Axon, EDC, and DEQ, 8 upgrades in total, 3, now 4 for EDC).

              When I got to the post-upgrade steps, I tried the more familiar infacmd migrateContents (referenced in the Upgrade guide) which failed repeatedly when I pointed it to the zip created in the backupContents command. I  unzipped the zip file and pointed the migrateContents command at that folder. No luck.

              As a test, I pointed the migrateContents command at the export folder created by (1) up above, and it worked. I then ran the migrateContents -verify and all came back successful.

              I've informed Informatica of this as well in the hopes that it will be clarified either way.

              chet



















              • 4. Re: EDC upgrade to v10.5 - Error  during ldm Catalog BackUp
                Srinivas Pai Guru

                Hello Anish

                 

                The error messages mention the below

                 

                (1) The domain/service name  is not recognizable or incorrect from the command line

                (2)  The SSL variables INFA_TRUSTSTORE_PASSWORD or INFA_TRUSTSTORE are incorrect.

                 

                I would recommend the below

                 

                (1) Use the keytool command to validate the password for the truststore.

                (2) Once you confirm the password for the truststore I see you have used the below command to encrypt the password

                ./pmpasswd changeit -e CRYPT_SYSTEM

                 

                Could you try to encrypt the password without passing the parameter "-e CRYPT_SYSTEM"

                 

                As this backup is blocking the upgrade to 10.5 I recommend you to raise a ticket with GCS and work on a speedy resolution for the backup generation issues.

                 

                Regards

                Srinivas