Salesforce deprecating APIs v7-v30 in Salesorce Summer  '22 release

Version 3

    Overview

    Salesforce is ending support for all SOAP, Rest and Bulk APIs up to and including v30. This affects the IICS CDI Salesforce Connector. Users will need to update their Salesforce Connector properties to use the Salesforce supported API versions.

     

    Description

    Salesforce is ending support for all SOAP, Rest and Bulk APIs till v30. More information can be found in Salesforce Documentation: https://developer.salesforce.com/blogs/2021/08/make-api-version-retirements-a-no-op

     

    This affects IICS CDI Salesforce Connector. Users will need to update their Salesforce Connector Properties (Service URL) to use the Salesforce supported API versions and reenter the Password, Security Token for Standard Connection Type and Consumer Key, Consumer Secret, Refresh Token fields for OAuth Connection Type again.

     

    Reference screenshots to update the connection are below:

     

    Standard Authentication:

     

    OAuth authentication: