Informatica PowerCenter 8 — Platforms and Features That Are Not Supported

What are we announcing?

There are platforms and features that are supported in previous releases of various Informatica products that are not supported in PowerCenter 8.x. See below for the complete list.

How much time will I have to adjust to these changes?

As of December 2005, customers and partners will have almost two years to complete any necessary mitigation. More specifically, customers can continue using and receiving support for current Informatica products that DO support these features/platforms for 18 months after release of PowerCenter 8.1. This is subject to the normal requirements for support and maintenance eligibility.
PowerCenter 8.x will not support these features.

Why will these platforms or features no longer be supported?

There are numerous reasons why software companies must end support for platforms and features, including, but not limited to:

  • The functionality is being provided in a different way. This may be the result of changes designed to provide greater functionality.
  • A third-party supplier (e.g., in the case of a platform vendor) is ending support for a version of their product.
  • A third-party supplier has an inconsistent or divergent road map making it difficult or impossible to maintain product alignment.
  • Technical changes in a company’s product and/or a third-party product do not allow continued support.
  • The product or feature (third-party or otherwise) has not garnered sufficient market share to justify continued support.

Who should I contact if I have additional questions about this?

If you have additional questions, please open a Service Request (SR) with Informatica Global Customer Support. Please use “PC7 EOL Question” for your SR Summary.

Which currently supported platforms and features will not be supported in PowerCenter® 8.x?

Note: These features and platforms will continue to be supported in PowerCenter 7.x or PowerAnalyzer™ 5.x (where applicable) for 18 months after release of PowerCenter 8.1.

Platform or Feature AreaWhat is happening?What will I need to do?Comments
Repository Database Support (Informix)

PowerCenter 8.x will not support the use of any Informix database as a repository.

Informix will continue to be supported as a source/target.

Customers will have to backup their existing repositories and restore them to a repository on a supported database. This can be accomplished using the pmrep backup command or the Repository Server Administration Client.

If using Metadata Reporter (renamed Repository Reports in PC8), customers will have to update their connection information to point to the new repository.

Due to query limitations in the Informix database, it is infeasible for PowerCenter 8 to support the use of Informix as a repository. Features such as High Availability, explicit checkout, and expression macros would require substantial, Informix-specific code, thus creating a veritable one-off product.
Repository Database Support (Teradata)

PowerCenter 8.x will not support the use of Teradata as a repository.

Teradata will continue to be supported as a source/target.

Customers will have to backup their existing repositories and restore them to a repository on a supported database. This can be accomplished using the pmrep backup command or the Repository Server Administration Client.

If using Metadata Reporter (renamed Repository Reports in PC8), customers will have to update their connection information to point to the new repository.

Teradata is optimized for its primary mission as an OLAP platform. PowerCenter's repository requires an OLTP/transaction-optimized database.
Metadata Exchange in PowerCenter Connect for SAP

PowerCenter 8.x will not support the Metadata Exchange capability provided by the PowerCenter® Connect for SAP R/3 with Metadata Exchange Option.

“PowerCenter Connect for SAP R/3” will continue to be supported.

Customers using the Metadata Exchange capability should plan to migrate to another solution before the support period for PowerCenter 7.x ends (18 months after the release of PowerCenter 8.1).Only the metadata exchange functionality is being obsolesced. “PowerCenter Connect for PeopleSoft” will continue to be supported.
Metadata Exchange in PowerCenter Connect for PeopleSoft

PowerCenter 8.x will not support the Metadata Exchange capability provided by the PowerCenter® Connect for PeopleSoft with Metadata Exchange Option

“PowerCenter Connect for PeopleSoft” will continue to be supported.

Customers using the Metadata Exchange capability should plan to migrate to another solution before the support period for PowerCenter 7.x ends (18 months after the release of PowerCenter 8.1).Only the metadata exchange functionality is being obsolesced. “PowerCenter Connect for PeopleSoft” will continue to be supported.
PowerCenter HIPAA SupportHIPAA Business ComponentsCustomers may license the compliance support in PowerCenter 7.1.3 and later versions provided via the Unstructured Data option (which also provides many other features). Customers will need to recreate their mappings and customizations.

The Unstructured Data option includes support for a wide variety of unstructured/semi-structured data formats. It also includes pre-built parsers for a number of standards including HL7, HIPAA, and SWIFT, among others.

Learn about PowerCenter options

PowerAnalyzer MobilePowerCenter AE 8.x will not support the ability to view PowerAnalyzer content from mobile devices. Mobile devices will continue to be able to receive dashboard alerts via SMS.>Customers should plan to migrate to other solutions before the support period for PowerAnalyzer 5.x ends (18 months after the release of PowerCenter 8.1).None.
Except where otherwise noted, the following apply to all Informatica products.
Apps serversBEA WL 6.1Migrate to a supported platformInitiated by vendor.
DatabasesTeradata V2R4 Source and TargetMigrate to a supported platformInitiated by vendor.
DatabasesSybase IQ 12.4.3Migrate to a supported platformInitiated by vendor.
DatabasesSybase ASE 12.0.xMigrate to a supported platformInitiated by vendor.
DatabasesOracle 8.0.xMigrate to a supported platformInitiated by vendor.
DatabasesInformix 8.3, 9.2 and 9.3Migrate to a supported platformInitiated by vendor.
DatabasesDB2 UDB 7 (not DB2 7.x on OS/390 or z/OS)Migrate to a supported platformInitiated by vendor.
Operating SystemsSolaris 7Migrate to a supported platformInitiated by vendor.
Operating SystemsHP-UX 11.0Migrate to a supported platformInitiated by vendor.
Operating SystemsAIX 5.1Migrate to a supported platformInitiated by vendor.
PowerCenter Connects™TIBCO v.6 PowerConnectMigrate to a supported platformInitiated by vendor.
SuperGluePowerCenter 5.x XConnectMigrate to a supported version of PowerCenter.PowerCenter 5.x is no longer supported.